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Creating a Tie Dye Top Using BodyShop and 
Paint Shop Pro

What we will be learning
This  tutorial  will  teach  you  the  basics  of 
clothing creation with BodyShop and how to 
make  a  spiffy  tie  dye  top  from  scratch. 
You’ll  also  be  learning  how  to  use  the 
exported  alpha  and  texture  layers  from 
BodyShop to help you perfect your designs.

What  you  need  and  what  you  need  to 
know
BodyShop,  obviously.  Use  the  version  that 
came  with  the  most  recently  published 
expansion pack you have (if any). We will be 
making the texture using Paint Shop Pro. Any 
version from version 7 upwards will do for this tutorial (or you can download 
a free trial of version XI from the Corel website). The main instructions are 
given using Paint Shop Pro Photo XI, but where the methods are different for 
version 7,  these will be highlighted in red. If you own a different image 
editing  application,  you  may  be  able  to  adapt  the  method  to  suit  your 
program if you’re proficient enough with it.

I’m assuming you have no knowledge of BodyShop for this tutorial, but you 
do need to have at least a basic working knowledge of PSP. If you don’t, now 
is a good time to read the manual ;)

Creating the tie dye texture
Load up BodyShop. This usually takes an age, even longer if you have a lot 
of custom content, so leave this to start up in the background and in the 
meantime, let’s load Paint Shop Pro.

Create a new file, dimensions 300 x 300 pixels, raster, background  colour 
transparent.  Save the file  as  TieDyeBlue.pspimage  (or TieDyeBlue.psp) in 
any convenient location. Be sure to save this file frequently.

Select the flood fill tool and change the mode to gradient. Now create a 
new gradient with the following settings:
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And save it as TieDyeBlue. Set the style to radial, angle to 0 and repeats to 
1. Now flood fill the canvas at 200 opacity and you’ll get this:

We’ll now add the shapes which will form the base of the tie-dye pattern. 
For simplicity we will use circles, but you could choose any shape you like, 
or simply straight lines.
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Select the ellipse tool (for version 7 select the preset shapes tool and then 
ellipse).  Check the Create  as  Vector  box,  and select  the  circle.  set  the 
line/stroke width to 4, the stroke colour to solid white and the fill colour to 
null.  If  using version 7, hold down Shift  while drawing to create perfect 
circles.

Now draw 4  circles  on  the  canvas,  each bigger  than  the  previous.  Your 
canvas should now look similar to this:

We will  now use  the  vector  select  tool  (shortcut  key O)  to  select  all  4 
circles. This tool does not show up by default in later versions of PSP. You 
have to manually add it to the tool palette by right-clicking on the tool 
palette, selecting Customise… > Commands > Tools and dragging the Object 
Selection tool onto your tool palette (see screenshot).
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Using this tool, drag a marquee over all the circles to select them. Then 
centre them with  the  centre button  on  the  tool  options  palette  on the 
canvas to get this.

On the Layers palette, right-click on your vector layer and select Merge > 
Merge All (Flatten).
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Now we have a single raster layer. We will now create the tie-dye effect. 
Select the Lighten/Darken tool (shortcut key L). Use the following settings 
(make sure thickness is set to 100):

Version 7:
Select the retouch tool

I had to use slightly different settings to get the same effect on version 7, as 
follows:

Now trace over the white circles with a zigzag motion to create the tie dye 
effect. This will probably be easier with a graphics tablet, but as you can 
see  a  decent  effect  can be  obtained  with  an  optical  mouse  (or  a  well-
cleaned ball mouse!). It’s a good idea to zoom in quite close while applying 
this effect as it can be a bit tricky getting it right.
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It’s already beginning to resemble tie-dyed fabric. Carry on until you have 
done all the circles. Feel free to tweak the tool settings until you find one 
that gives you the best effect. Your image should look something like this:

Let’s make the effect a bit more realistic by applying a slight blur. Go to 
Effects > Blur > Gaussian Blur and set the radius to a value between 1.00 
and 2.00. Here I’ve used 1.20:

Now let’s return to BodyShop  and try out the texture.
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Switch back to the BodyShop window. Click Create Parts, Start New Project, 
Create Clothing. Adult Female clothes are selected by default. Click on the 
Everyday icon that appears, then Tops. Scroll through the list towards the 
end until you reach the sleeveless tops and select one. We’ll use the brown 
one shown here. Then click on the ‘Export Selected Textures’ button.

You’ll be prompted to enter a name for the project. Call it TieDyeTop and 
click the accept button. Don’t click anything else yet!

Switch  back to  Paint  Shop Pro.  Go to  File  >  Open… and navigate  to  My 
Documents > EA Games > The Sims 2 > Projects > TieDyeTop. There will be 4 
files  in  there.  We want  this  one:  top~stdMatBaseTextureName.bmp. Your 
image will look like this.

 

7



silverssimstuff.wordpress.com

Now switch back to the window containing your tie dye texture. Copy it, 
then back to the clothing texture and Paste As New Layer (Ctrl + L).

Use the Pick Tool (K) (the deformation tool on version 7) to move it until it is 
over the right hand top. Like this:

Save  the  file  (Ctrl+S).  You’ll  be  warned  that  the  saved  file  will  be  a 
flattened image. Click Yes.

Note: If you close and re-load this file, all your layers will be lost. If your PC 
is prone to crashing, I would advise you to frequently use File > Save Copy 
As... to save a backup of the file in .pspimage (or .psp) format.

Now go back to BodyShop and press the refresh button (the circular arrow). 
You can see your top start to take shape. It still needs a fair bit of work 
though. Let’s go back to Paint Shop Pro. Using the Pick tool again, take hold 
of the bottom-right handle on the marquee and drag it down just enough 
until the tie dye texture covers the entire right hand top, then save and 
refresh your preview in BodyShop.

That’s better!
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Using the alpha layer as a mask
We can make use of the alpha image file exported by BodyShop to help us 
align the clothing texture properly. Sometimes this is necessary so  you to 
know where your texture should go. For instance, if you export a texture 
from a downloaded mesh’s base texture, like this:

Then you may end up with a canvas that looks like this:

Not very helpful!

But apply its alpha channel as a mask… and suddenly all becomes clear!

Right, back to our top. Navigate back to the TieDyeTop folder again and 
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open  the  file  named  top~stdMatBaseTextureName_alpha.bmp  in  PSP. 
(Version 7 users, the method is slightly different, see the next page.) Switch 
back to the top’s texture image and go to Layers > New Mask Layer > From 
Image… then use the settings shown below:

 

This  will  create  a  mask  over  the  current  layer.  Now  right-click  on  the 
background  layer  and  select  Promote  Background  Layer  (or  Promote  to 
Layer). Now drag all the layers into the same group as the mask, so your 
layer palette will look like the one shown below. Make sure the mask layer is 
at the top of the list.
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Version 7: It is not possible to group raster layers in version 7. The method 
here is Masks > New > From Image… and select the alpha layer as above. 
Then you will have to apply this mask to each individual layer by selecting 
each remaining layer in turn, then clicking on the Create Mask button for 
each on the Layer Palette, here: 

 

If the centre of the circles on the top aren't in line with the centre of the 
top, use the Pick Tool again to align the texture in the middle. The best way 
to do this is to use guides, as below, then use the centre marker of the Pick 
marquee to align the texture properly.

Now we need to apply the same texture to the back of the top. First save 
and preview your top to make sure you are happy with the position of the 
pattern. Now, on the layers palette, right-click the tie dye layer and select 
Duplicate. It’s easy to make sure the textures’ positions match. Just go to 
Image > Mirror and the textures for the front and back of the top should be 
aligned.

Once you’re happy with the position of your textures, save the image and 
preview again in BodyShop.
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Tada!

Now we can add noise to the texture to make it  look like worn cotton. 
Merge  all  the  layers  by  right-clicking  on  any  in  the  layer  palette  and 
selecting Merge > Merge All (Flatten).

Go  to  Effects  >  Add/Remove  Noise  >  Add  Noise…  Select  Gaussian, 
Monochrome and set the level to about 20% (experiment with the level to 
find one you like), then apply.  (In version 7, go to Effects > Noise > Add… 
and select Uniform and 20%.)

Using the Exported Bumpmap Image to Create an Illusion of Relief

Some clothing exports a 3rd texture image (the bumpmap – we will discuss 
this  later)  which  can be used to  give the  illusion of  relief  (3D)  to  your 
clothing.  In  this  case  the  image  is  called 
top~stdMatNormalMapTextureName.bmp. We can use this  with Paint  Shop 
Pro’s Texture Effect to remove the ‘flatness’ of the texture.

Copy this file to My Documents > My PSP Files > Textures  (version 7 users: 
copy this to the Textures directory in the location you installed PSP)  and 
give it a meaningful name (e.g. SleevelessTopF).

First  make  a  duplicate  of  the  layer.  Now  on  the  topmost  (i.e.  the 
duplicated)  layer,  go  to  Effects   >  Texture  Effects  >  Texture  and  in  the 
dialogue  select  SleevelessTopF  (or  whatever  you  named  it)  with  the 
following settings:
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Save your file. Preview in BodyShop.

I’ve zoomed in here by pressing F3. As you can see the texture has created a 
creasing effect, which makes the fabric look more realistic, but also dark 
edges which we don’t want. This is why we did this effect on a duplicate 
layer! Go back to PSP and select the Eraser Tool (X). On the duplicated layer 
again, erase over all the dark edges. Save and preview again:

Feel  free to  undo and redo the Texture Effect with  different  settings  if 
you’re unhappy with the settings used above.

The Bumpmap
With  more  advanced  graphics  cards,  the  bumpmap  texture  adds  the  3D 
effect  for  you.  Since  we  have  done  this  manually  we  don't  want  the 
bumpmap adding even more depth to our texture if we have a graphics card 
capable of rendering it (if your card doesn't have Pixel Shader it will not 
show  up  on  your  texture  anyway).  Open  the  bumpmap  file  again 
(top~stdMatNormalMapTextureName.bmp)  in  your  TieDyeTop  folder.  Now 
flood fill the entire canvas with the RGB colour  #808080 (or 128 128 128). 
Save this file.
(More on bumpmaps here: http://www.modthesims2.com/showthread.php?t=92444)
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If you’re happy with the way your top looks, make a final save and check 
out your masterpiece in BodyShop! Now add a tool tip (you can just put 
their name in here so anyone whom you share your creation with knows who 
to credit) and click on Import to Game. You’re done!

Sharing your creations
Now that you’ve created your spiffy top, you might want to share it with 
others. Do not share the package file in the TieDyeTop folder; this will not 
work. You need to navigate to your SavedSims folder in My Documents > EA 
Games > The Sims 2. The file name will be a random hexadecimal number 
followed by _yourprojectname.package (see below).

This  is  the  file  that  you  need  to  use  when  sharing  or  uploading  your 
creation.

Wahey! All Done!

There! You did it! Now you’ve mastered the tie dye technique, have a go 
making more zany creations with different shapes and colours. How about 
hot pink with stars, violet with hearts or lime green with wavy lines? Or 
even a crazy combination of all three?
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